// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*file:\W+(?<Trip>[\d-]+)_.*").unwrap();
let string = "1 <PNR>JDU8T3</PNR> in file: 1003-4347-316_201801220319.xml";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}