$re = '/.*file:\W+(?<Trip>[\d-]+)_.*/';
$str = '1 <PNR>JDU8T3</PNR> in file: 1003-4347-316_201801220319.xml';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);