# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"watersportsoutlet.com([\D]{2}.\/|\/[\D]{2}-[^us]{2}\/)"
test_str = ("https://www.watersportsoutlet.com/en-nz/fhjhg-p-645653.html\n"
"https://www.watersportsoutlet.com/en-us/fhjhg-p-645653.html\n"
"https://www.watersportsoutlet.com/es-us/fhjhg-p-645653.html\n"
"https://www.watersportsoutlet.com/fhjhg-p-645653.html\n"
"https://www.watersportsoutlet.com/no-no/fhjhg-p-645653.html\n"
"https://www.watersportsoutlet.com/fi-fi/fhjhg-p-645653.html\n"
"https://www.watersportsoutlet.com.au/fhjhg-p-645653.html")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.