$re = '/watersportsoutlet.com([\D]{2}.\/|\/[\D]{2}-[^us]{2}\/)/m';
$str = 'https://www.watersportsoutlet.com/en-nz/fhjhg-p-645653.html
https://www.watersportsoutlet.com/en-us/fhjhg-p-645653.html
https://www.watersportsoutlet.com/es-us/fhjhg-p-645653.html
https://www.watersportsoutlet.com/fhjhg-p-645653.html
https://www.watersportsoutlet.com/no-no/fhjhg-p-645653.html
https://www.watersportsoutlet.com/fi-fi/fhjhg-p-645653.html
https://www.watersportsoutlet.com.au/fhjhg-p-645653.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);