// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\s*sources\s*: \[\s*"(.*?)""#).unwrap();
let string = "<script type='text/javascript'>var player = new Clappr.Player({
sources: [\"https://stream246.uqload.com/3rfkvsgbgrw2q4drdjh7flnhb2lf6ff2m6pnbxhevplrwbk2snkkbvddzajq/v.mp4\"],
preload: 'none',
poster: \"https://stream246.uqload.com/i/05/00307/jge6igyfdjim_xt.jpg\",
width: \"100%\",
height: \"100%\",
disableVideoTagContextMenu: true,
parentId: \"#vplayer\"
});";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}