#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\s*sources\s*: \[\s*"(.*?)""
Local $sString = "<script type='text/javascript'>var player = new Clappr.Player({" & @CRLF & _
" sources: ["https://stream246.uqload.com/3rfkvsgbgrw2q4drdjh7flnhb2lf6ff2m6pnbxhevplrwbk2snkkbvddzajq/v.mp4"], " & @CRLF & _
" preload: 'none'," & @CRLF & _
" poster: "https://stream246.uqload.com/i/05/00307/jge6igyfdjim_xt.jpg", " & @CRLF & _
" width: "100%"," & @CRLF & _
" height: "100%"," & @CRLF & _
" disableVideoTagContextMenu: true," & @CRLF & _
" parentId: "#vplayer"" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" });"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")