$re = '/([0-9]{2}(EU|eu)[A-Za-z]{2}[0-9]{3})/m';
$str = '18EUIT001';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);