package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9]{2}(EU|eu)[A-Za-z]{2}[0-9]{3})`)
var str = `18EUIT001`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}