re = /(?<=name is )(.*)(?=,)/m
str = 'is, My name is Sir John watson Bler, and I am a developer. Is it ok?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end