$re = '/(?<=name is )(.*)(?=,)/m';
$str = 'is, My name is Sir John watson Bler, and I am a developer. Is it ok?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);