# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(([NnSs+-])?([0-8]?\d(\.\d*)?|90(\.0*)?)([°˚º^~*NnSs+-])*)([,:;\s|\/\\-]+)(([EeWw+-])*([0]?\d?\d(\.\d*)?|1[0-7]\d(\.\d*)?|180(\.0*)?)[°˚º^~*]*([EeWw+-])*)[\s]*$"
test_str = ("//check all zeros\n"
"0 0\n"
"0.0 0.0\n"
"0.000 0.000\n"
"0.0000 0.0000\n\n"
"//check plus and minus signs\n"
"+0 0\n"
"+0.0 0.0\n"
"+0.000 0.000\n"
"+0.0000 0.0000\n\n"
"0 +0\n"
"0.0 +0.0\n"
"0.000 +0.000\n"
"0.0000 +0.0000\n\n"
"+0 +0\n"
"+0.0 +0.0\n"
"+0.000 +0.000\n"
"+0.0000 +0.0000\n\n"
"-0 0\n"
"-0.0 0.0\n"
"-0.000 0.000\n"
"-0.0000 0.0000\n\n"
"0 -0\n"
"0.0 -0.0\n"
"0.000 -0.000\n"
"0.0000 -0.0000\n\n"
"-0 -0\n"
"-0.0 -0.0\n"
"-0.000 -0.000\n"
"-0.0000 -0.0000\n\n"
"0+ 0\n"
"0.0+ 0.0\n"
"0.000+ 0.000\n"
"0.0000+ 0.0000\n\n"
"0 0+\n"
"0.0 0.0+\n"
"0.000 0.000+\n"
"0.0000 0.0000+\n\n"
"0- 0\n"
"0.0- 0.0\n"
"0.000- 0.000\n"
"0.0000- 0.0000\n\n"
"0 0-\n"
"0.0 0.0-\n"
"0.000 0.000-\n"
"0.0000 0.0000-\n\n"
"0+ 0+\n"
"0.0+ 0.0+\n"
"0.000+ 0.000+\n"
"0.0000+ 0.0000+\n\n"
"0- 0-\n"
"0.0- 0.0-\n"
"0.000- 0.000-\n"
"0.0000- 0.0000-\n\n"
"//check hemipshere\n"
"0N 0\n"
"0.0N 0.0\n"
"0.000N 0.00\n"
"0.0000N 0.000\n\n"
"0N 0E\n"
"0.0N 0.0E\n"
"0.000N 0.00E\n"
"0.0000N 0.000E\n\n"
"0N 0W\n"
"0.0N 0.0W\n"
"0.000N 0.00W\n"
"0.0000N 0.000W\n\n"
"0S 0\n"
"0.0S 0\n"
"0.000S 0\n"
"0.0000S 0\n\n"
"0S 0E\n"
"0.0S 0.0E\n"
"0.000S 0.00E\n"
"0.0000S 0.000E\n\n"
"0S 0W\n"
"0.0S 0.0W\n"
"0.000S 0.00W\n"
"0.0000S 0.000W\n\n"
"//check degree symbols\n"
"0° 0°\n"
"0.0° 0.0°\n"
"0.000° 0.000°\n"
"0.0000° 0.0000°\n\n"
"0˚ 0˚\n"
"0.0˚ 0.0˚\n"
"0.000˚ 0.000˚\n"
"0.0000˚ 0.0000˚\n\n"
"0º 0º\n"
"0.0º 0.0º\n"
"0.000º 0.000º\n"
"0.0000º 0.0000º\n\n"
"0^ 0^\n"
"0.0^ 0.0^\n"
"0.000^ 0.000^\n"
"0.0000^ 0.0000^\n\n"
"0* 0*\n"
"0.0* 0.0*\n"
"0.000* 0.000*\n"
"0.0000* 0.0000*\n\n"
"0~ 0~\n"
"0.0~ 0.0~\n"
"0.000~ 0.000~\n"
"0.0000~ 0.0000~\n\n"
"//check sperators\n\n"
"0,0\n"
"0.0,0.0\n"
"0.000,0.000\n"
"0.0000,0.0000\n\n"
"0-0\n"
"0.0-0.0\n"
"0.000-0.000\n"
"0.0000-0.0000\n\n"
"0:0\n"
"0.0:0.0\n"
"0.000:0.000\n"
"0.0000:0.0000\n\n"
"0;0\n"
"0.0;0.0\n"
"0.000;0.000\n"
"0.0000;0.0000\n\n"
"0|0\n"
"0.0|0.0\n"
"0.000|0.000\n"
"0.0000|0.0000\n\n"
"0/0\n"
"0.0/0.0\n"
"0.000/0.000\n"
"0.0000/0.0000\n\n"
"0\\0\n"
"0.0\\0.0\n"
"0.000\\0.000\n"
"0.0000\\0.0000\n\n"
"90,180\n"
"45,45\n\n\n"
"//invalid\n"
"90.123 0.0\n"
"91.0 0\n"
"91.00 0\n"
"91.0 0.0\n"
"91.00 0.00\n"
"0 180.1\n"
"0 181\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.