#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(([NnSs+-])?([0-8]?\d(\.\d*)?|90(\.0*)?)([°˚º^~*NnSs+-])*)([,:;\s|\/\\-]+)(([EeWw+-])*([0]?\d?\d(\.\d*)?|1[0-7]\d(\.\d*)?|180(\.0*)?)[°˚º^~*]*([EeWw+-])*)[\s]*$"
Local $sString = "//check all zeros" & @CRLF & _
"0 0" & @CRLF & _
"0.0 0.0" & @CRLF & _
"0.000 0.000" & @CRLF & _
"0.0000 0.0000" & @CRLF & _
"" & @CRLF & _
"//check plus and minus signs" & @CRLF & _
"+0 0" & @CRLF & _
"+0.0 0.0" & @CRLF & _
"+0.000 0.000" & @CRLF & _
"+0.0000 0.0000" & @CRLF & _
"" & @CRLF & _
"0 +0" & @CRLF & _
"0.0 +0.0" & @CRLF & _
"0.000 +0.000" & @CRLF & _
"0.0000 +0.0000" & @CRLF & _
"" & @CRLF & _
"+0 +0" & @CRLF & _
"+0.0 +0.0" & @CRLF & _
"+0.000 +0.000" & @CRLF & _
"+0.0000 +0.0000" & @CRLF & _
"" & @CRLF & _
"-0 0" & @CRLF & _
"-0.0 0.0" & @CRLF & _
"-0.000 0.000" & @CRLF & _
"-0.0000 0.0000" & @CRLF & _
"" & @CRLF & _
"0 -0" & @CRLF & _
"0.0 -0.0" & @CRLF & _
"0.000 -0.000" & @CRLF & _
"0.0000 -0.0000" & @CRLF & _
"" & @CRLF & _
"-0 -0" & @CRLF & _
"-0.0 -0.0" & @CRLF & _
"-0.000 -0.000" & @CRLF & _
"-0.0000 -0.0000" & @CRLF & _
"" & @CRLF & _
"0+ 0" & @CRLF & _
"0.0+ 0.0" & @CRLF & _
"0.000+ 0.000" & @CRLF & _
"0.0000+ 0.0000" & @CRLF & _
"" & @CRLF & _
"0 0+" & @CRLF & _
"0.0 0.0+" & @CRLF & _
"0.000 0.000+" & @CRLF & _
"0.0000 0.0000+" & @CRLF & _
"" & @CRLF & _
"0- 0" & @CRLF & _
"0.0- 0.0" & @CRLF & _
"0.000- 0.000" & @CRLF & _
"0.0000- 0.0000" & @CRLF & _
"" & @CRLF & _
"0 0-" & @CRLF & _
"0.0 0.0-" & @CRLF & _
"0.000 0.000-" & @CRLF & _
"0.0000 0.0000-" & @CRLF & _
"" & @CRLF & _
"0+ 0+" & @CRLF & _
"0.0+ 0.0+" & @CRLF & _
"0.000+ 0.000+" & @CRLF & _
"0.0000+ 0.0000+" & @CRLF & _
"" & @CRLF & _
"0- 0-" & @CRLF & _
"0.0- 0.0-" & @CRLF & _
"0.000- 0.000-" & @CRLF & _
"0.0000- 0.0000-" & @CRLF & _
"" & @CRLF & _
"//check hemipshere" & @CRLF & _
"0N 0" & @CRLF & _
"0.0N 0.0" & @CRLF & _
"0.000N 0.00" & @CRLF & _
"0.0000N 0.000" & @CRLF & _
"" & @CRLF & _
"0N 0E" & @CRLF & _
"0.0N 0.0E" & @CRLF & _
"0.000N 0.00E" & @CRLF & _
"0.0000N 0.000E" & @CRLF & _
"" & @CRLF & _
"0N 0W" & @CRLF & _
"0.0N 0.0W" & @CRLF & _
"0.000N 0.00W" & @CRLF & _
"0.0000N 0.000W" & @CRLF & _
"" & @CRLF & _
"0S 0" & @CRLF & _
"0.0S 0" & @CRLF & _
"0.000S 0" & @CRLF & _
"0.0000S 0" & @CRLF & _
"" & @CRLF & _
"0S 0E" & @CRLF & _
"0.0S 0.0E" & @CRLF & _
"0.000S 0.00E" & @CRLF & _
"0.0000S 0.000E" & @CRLF & _
"" & @CRLF & _
"0S 0W" & @CRLF & _
"0.0S 0.0W" & @CRLF & _
"0.000S 0.00W" & @CRLF & _
"0.0000S 0.000W" & @CRLF & _
"" & @CRLF & _
"//check degree symbols" & @CRLF & _
"0° 0°" & @CRLF & _
"0.0° 0.0°" & @CRLF & _
"0.000° 0.000°" & @CRLF & _
"0.0000° 0.0000°" & @CRLF & _
"" & @CRLF & _
"0˚ 0˚" & @CRLF & _
"0.0˚ 0.0˚" & @CRLF & _
"0.000˚ 0.000˚" & @CRLF & _
"0.0000˚ 0.0000˚" & @CRLF & _
"" & @CRLF & _
"0º 0º" & @CRLF & _
"0.0º 0.0º" & @CRLF & _
"0.000º 0.000º" & @CRLF & _
"0.0000º 0.0000º" & @CRLF & _
"" & @CRLF & _
"0^ 0^" & @CRLF & _
"0.0^ 0.0^" & @CRLF & _
"0.000^ 0.000^" & @CRLF & _
"0.0000^ 0.0000^" & @CRLF & _
"" & @CRLF & _
"0* 0*" & @CRLF & _
"0.0* 0.0*" & @CRLF & _
"0.000* 0.000*" & @CRLF & _
"0.0000* 0.0000*" & @CRLF & _
"" & @CRLF & _
"0~ 0~" & @CRLF & _
"0.0~ 0.0~" & @CRLF & _
"0.000~ 0.000~" & @CRLF & _
"0.0000~ 0.0000~" & @CRLF & _
"" & @CRLF & _
"//check sperators" & @CRLF & _
"" & @CRLF & _
"0,0" & @CRLF & _
"0.0,0.0" & @CRLF & _
"0.000,0.000" & @CRLF & _
"0.0000,0.0000" & @CRLF & _
"" & @CRLF & _
"0-0" & @CRLF & _
"0.0-0.0" & @CRLF & _
"0.000-0.000" & @CRLF & _
"0.0000-0.0000" & @CRLF & _
"" & @CRLF & _
"0:0" & @CRLF & _
"0.0:0.0" & @CRLF & _
"0.000:0.000" & @CRLF & _
"0.0000:0.0000" & @CRLF & _
"" & @CRLF & _
"0;0" & @CRLF & _
"0.0;0.0" & @CRLF & _
"0.000;0.000" & @CRLF & _
"0.0000;0.0000" & @CRLF & _
"" & @CRLF & _
"0|0" & @CRLF & _
"0.0|0.0" & @CRLF & _
"0.000|0.000" & @CRLF & _
"0.0000|0.0000" & @CRLF & _
"" & @CRLF & _
"0/0" & @CRLF & _
"0.0/0.0" & @CRLF & _
"0.000/0.000" & @CRLF & _
"0.0000/0.0000" & @CRLF & _
"" & @CRLF & _
"0\0" & @CRLF & _
"0.0\0.0" & @CRLF & _
"0.000\0.000" & @CRLF & _
"0.0000\0.0000" & @CRLF & _
"" & @CRLF & _
"90,180" & @CRLF & _
"45,45" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"//invalid" & @CRLF & _
"90.123 0.0" & @CRLF & _
"91.0 0" & @CRLF & _
"91.00 0" & @CRLF & _
"91.0 0.0" & @CRLF & _
"91.00 0.00" & @CRLF & _
"0 180.1" & @CRLF & _
"0 181" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")