import Foundation
let pattern = #"([+-])?(\d\d)(?:(:?)|\*)([0-5]\d)(?:(?:(\3)|\')((?:[0-5]\d)(?:\.\d+)?))?([NS])?\/([+-])?([01]\d\d)\3([0-5]\d)(?:\3((?:[0-5]\d)(?:\.\d+)?))?([EW])?\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
7532N/10458W
7532/10458
753257/1045843
753257N/1045843E
753257.1/1045843.2
753257.1N/1045843.2E
75:32N/104:58W
75:32/104:58
75:32:57/104:58:43
75:32:57N/104:58:43E
75:32:57.1/104:58:43.2
75:32:57.1N/104:58:43.2E
75*32/10458
75*32'57"N/104*58'43"E
75*32'57.1"/104*58'43.2"
75*32'57.1"N/104*58'43.2"E
75:32/10458
75:3257N/104:58:43E
75:32:57.1/104:5843.2
75:32:57.1N/1045843.2E
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)