# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([+-])?(\d\d)(?:(:?)|\*)([0-5]\d)(?:(?:(\3)|\')((?:[0-5]\d)(?:\.\d+)?))?([NS])?\/([+-])?([01]\d\d)\3([0-5]\d)(?:\3((?:[0-5]\d)(?:\.\d+)?))?([EW])?\b"
test_str = ("7532N/10458W\n"
"7532/10458\n"
"753257/1045843\n"
"753257N/1045843E\n"
"753257.1/1045843.2 \n"
"753257.1N/1045843.2E\n"
"75:32N/104:58W\n"
"75:32/104:58\n"
"75:32:57/104:58:43\n"
"75:32:57N/104:58:43E\n"
"75:32:57.1/104:58:43.2\n"
"75:32:57.1N/104:58:43.2E\n\n\n\n"
"75*32/10458\n"
"75*32'57\"N/104*58'43\"E\n"
"75*32'57.1\"/104*58'43.2\"\n"
"75*32'57.1\"N/104*58'43.2\"E \n\n"
"75:32/10458\n"
"75:3257N/104:58:43E\n"
"75:32:57.1/104:5843.2\n"
"75:32:57.1N/1045843.2E \n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.