re = /^(?<protocol>[a-z\-]+)?:?(?<slash>\/\/)?(?<host>[a-zA-Z0-9\.]+)?(?P<port>:\d+)?$/m
str = 'https://example.domain
http://example.domain
//example.domain
//example.com
https://example.com:34
//example.com:23
example.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end