$re = '/^4[0-9]{12}(?:[0-9]{3})?$/';
$str = '4231200000951458';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);