package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^4[0-9]{12}(?:[0-9]{3})?$`)
var str = `4231200000951458`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}