import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9]{9}|\\d{3}[ -]*\\d{2}[ -]*\\d{4}|[ -]*(?:[0-9][ -]*){9}";
final String string = "225268541\n"
+ "235-55-8459\n"
+ " 26 55 6559\n"
+ " 261 25-4658\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}