#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[0-9]{9}|\d{3}[ -]*\d{2}[ -]*\d{4}|[ -]*(?:[0-9][ -]*){9}"
Local $sString = "225268541" & @CRLF & _
"235-55-8459" & @CRLF & _
" 26 55 6559" & @CRLF & _
" 261 25-4658" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")