// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(\d{1,2}|1\d{2}|2[0-4]\d|25[0-5])\b\.\b(\d{1,2}|1\d{2}|2[0-4]\d|25[0-5])\b\.\b(\d{1,2}|1\d{2}|2[0-4]\d|25[0-5])\b\.\b(\d{1,2}|1\d{2}|2[0-4]\d|25[0-5])\b").unwrap();
let string = "invalidos:
192.268.0.1
1.333.1.1
192.168.0.256
256.256.256.256
validos:
192.168.0.1
127.0.0.1
10.0.0.255
10.11.12.0
255.255.255.255
0.0.0.0
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}