use strict;
my $str = 'invalidos:
192.268.0.1
1.333.1.1
192.168.0.256
256.256.256.256
validos:
192.168.0.1
127.0.0.1
10.0.0.255
10.11.12.0
255.255.255.255
0.0.0.0
';
my $regex = qr/\b(\d{1,2}|1\d{2}|2[0-4]\d|25[0-5])\b\.\b(\d{1,2}|1\d{2}|2[0-4]\d|25[0-5])\b\.\b(\d{1,2}|1\d{2}|2[0-4]\d|25[0-5])\b\.\b(\d{1,2}|1\d{2}|2[0-4]\d|25[0-5])\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}