const regex = new RegExp('(\\b\\w+\\b)(?=.*\\b\\1\\b)', 'gm')
const str = `Austria, "Belgium", "Bulgaria", "Czech Republic", "Cyprus", "Denmark", "Estonia", "Finland", "France", "Germany", Austria, "Greece", "Hungary", "Ireland", "Italy", "Latvia", "Lithuania", "Luxembourg", "Malta", "The Netherlands", "Poland", "Portugal", "Romania", "Slovenia", "Slovakia", "Spain", "Sweden", "United Kingdom", "Denmark", "Austria"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}