using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\b\w+\b)(?=.*\b\1\b)";
string input = @"Austria, ""Belgium"", ""Bulgaria"", ""Czech Republic"", ""Cyprus"", ""Denmark"", ""Estonia"", ""Finland"", ""France"", ""Germany"", Austria, ""Greece"", ""Hungary"", ""Ireland"", ""Italy"", ""Latvia"", ""Lithuania"", ""Luxembourg"", ""Malta"", ""The Netherlands"", ""Poland"", ""Portugal"", ""Romania"", ""Slovenia"", ""Slovakia"", ""Spain"", ""Sweden"", ""United Kingdom"", ""Denmark"", ""Austria""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}