# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[1-9]\d*(?[\,\.]\d{3})?$"
test_str = ("3434.34534..45435.3454\n"
"2323.23\n"
"10.34\n"
"10..\n"
"2123.23.232\n"
"23432432\n"
"23432frerw33243\n"
"00076785.75675\n"
"fsf3454dfgdfg\n"
"fdgd43545.34543\n"
"435435.435.345\n"
"1000000\n"
"1.77676767676\n"
"145435.534545\n"
"34.43\n"
"3545.34545\n"
"4324324324.324324324324dgdg\n"
"324342\n"
"2343.2343\n"
"32224323.\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.