import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[1-9]\\d*(?[\\,\\.]\\d{3})?$";
final String string = "3434.34534..45435.3454\n"
+ "2323.23\n"
+ "10.34\n"
+ "10..\n"
+ "2123.23.232\n"
+ "23432432\n"
+ "23432frerw33243\n"
+ "00076785.75675\n"
+ "fsf3454dfgdfg\n"
+ "fdgd43545.34543\n"
+ "435435.435.345\n"
+ "1000000\n"
+ "1.77676767676\n"
+ "145435.534545\n"
+ "34.43\n"
+ "3545.34545\n"
+ "4324324324.324324324324dgdg\n"
+ "324342\n"
+ "2343.2343\n"
+ "32224323.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}