re = /([A-Za-z]+) +\1/
str = ' i am the the man
i am the man
i amd the the man
i can can run all day'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end