$re = '/([A-Za-z]+) +\1/';
$str = ' i am the the man
i am the man
i amd the the man
i can can run all day';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);