$re = '/(?:(?=(?<a>\w+)?)\k<a>(?:;(\w+?)=(\d+?))*?)?/y';
$str = 'ab;c=1;d=2;e=f,ab;x=3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);