using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?=(?<a>\w+)?)\k<a>(?:;(\w+?)=(\d+?))*?)?";
string input = @"ab;c=1;d=2;e=f,ab;x=3";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}