re = /^([aeiou])[a-z]*\1$|^[aeiou]$/m
str = 'artta
artta
xyyx
1234rr1
casdcfc
arffsdea'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end