$re = '/^([aeiou])[a-z]*\1$|^[aeiou]$/m';
$str = 'artta
artta
xyyx
1234rr1
casdcfc
arffsdea';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);