re = /^\b(?<cRegexGroupsName>.*?)\s/m
str = 'RODRIGUEZ FERNANDEZ FRANCISCO JAVIER'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end