$re = '/^\b(?<cRegexGroupsName>.*?)\s/m';
$str = 'RODRIGUEZ FERNANDEZ FRANCISCO JAVIER';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);