$re = '/^(?:ecp\.eset\.systems|(?:(?:m\.)?esa|h1\-esa0[1-4]|h3\-esa2\-0[1-4]\-v)\.eset\.com)$/m';
$str = 'ecp.eset.systems
esa.eset.com
m.esa.eset.com
h1-esa01.eset.com
h1-esa02.eset.com
h1-esa03.eset.com
h1-esa04.eset.com
h3-esa2-01-v.eset.com
h3-esa2-02-v.eset.com
h3-esa2-03-v.eset.com
h3-esa2-04-v.eset.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);