const regex = /^(?:ecp\.eset\.systems|(?:(?:m\.)?esa|h1\-esa0[1-4]|h3\-esa2\-0[1-4]\-v)\.eset\.com)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:ecp\\.eset\\.systems|(?:(?:m\\.)?esa|h1\\-esa0[1-4]|h3\\-esa2\\-0[1-4]\\-v)\\.eset\\.com)$', 'gm')
const str = `ecp.eset.systems
esa.eset.com
m.esa.eset.com
h1-esa01.eset.com
h1-esa02.eset.com
h1-esa03.eset.com
h1-esa04.eset.com
h3-esa2-01-v.eset.com
h3-esa2-02-v.eset.com
h3-esa2-03-v.eset.com
h3-esa2-04-v.eset.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}