using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(((\d\d)(([0][13578]|[1][0]|[1][2])([0][1-9]|[1-2][0-9]|[3][0-1])|([0][469]|[1][1])([0][1-9]|[1-2][0-9]|[3][0])|([0][2])([0][1-9]|[1][0-9]|[2][0-8])))|([02468][048]|[13579][26])([0][2])([0][1-9]|[1-2][0-9]))-([0-1][0-9]|[2][0-3])_([0-5][0-9])_([0-5][0-9])$";
string input = @"220129-10_16_00
220131-10_16_00
220131-10_16_00
010219-01_00_00
220429-23_16_00
220429-00_59_59";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}