#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(((\d\d)(([0][13578]|[1][0]|[1][2])([0][1-9]|[1-2][0-9]|[3][0-1])|([0][469]|[1][1])([0][1-9]|[1-2][0-9]|[3][0])|([0][2])([0][1-9]|[1][0-9]|[2][0-8])))|([02468][048]|[13579][26])([0][2])([0][1-9]|[1-2][0-9]))-([0-1][0-9]|[2][0-3])_([0-5][0-9])_([0-5][0-9])$"
Local $sString = "220129-10_16_00" & @CRLF & _
"220131-10_16_00" & @CRLF & _
"220131-10_16_00" & @CRLF & _
"010219-01_00_00" & @CRLF & _
"220429-23_16_00" & @CRLF & _
"220429-00_59_59"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")