use strict;
my $str = 'class TypeInfo;
TURBO_CLASS() //uywefbcgfwbcrgbycbcuynuyb
class TestClass : private Test, public TestTest, protected BaseClass
{
TURBO_CLASS_H_GENERATION()
private:
TestClass * tc;
TURBO_PROPERTY()
std::string var1 = "Default" ; //Reflected
TURBO_PROPERTY()
int var2 = 2; //Reflected
TestClass* tc2;
TURBO_PROPERTY()
int var3 = 3; //Reflected
public:
TestClass() = default;
TestClass(std::string&& s, int i, int i2);
};
TURBO_CLASS() //uywefbcgfwbcrgbycbcuynuyb
class TestClass2 : private Test, public TestTest, protected BaseClass
{
TURBO_CLASS_H_GENERATION()
private:
TestClass * tc;
TURBO_PROPERTY()
std::string var1 = "Default" ; //Reflected
TURBO_PROPERTY()
int var2 = 2; //Reflected
TestClass* tc2;
TURBO_PROPERTY()
int var3 = 3; //Reflected
public:
TestClass() = default;
TestClass(std::string&& s, int i, int i2);
};
#endif';
my $regex = qr/(\s*=.*;)/p;
my $subst = ';';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";