package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\s*=.*;)`)
var str = `class TypeInfo;
TURBO_CLASS() //uywefbcgfwbcrgbycbcuynuyb
class TestClass : private Test, public TestTest, protected BaseClass
{
TURBO_CLASS_H_GENERATION()
private:
TestClass * tc;
TURBO_PROPERTY()
std::string var1 = "Default" ; //Reflected
TURBO_PROPERTY()
int var2 = 2; //Reflected
TestClass* tc2;
TURBO_PROPERTY()
int var3 = 3; //Reflected
public:
TestClass() = default;
TestClass(std::string&& s, int i, int i2);
};
TURBO_CLASS() //uywefbcgfwbcrgbycbcuynuyb
class TestClass2 : private Test, public TestTest, protected BaseClass
{
TURBO_CLASS_H_GENERATION()
private:
TestClass * tc;
TURBO_PROPERTY()
std::string var1 = "Default" ; //Reflected
TURBO_PROPERTY()
int var2 = 2; //Reflected
TestClass* tc2;
TURBO_PROPERTY()
int var3 = 3; //Reflected
public:
TestClass() = default;
TestClass(std::string&& s, int i, int i2);
};
#endif`
var substitution = ";"
fmt.Println(re.ReplaceAllString(str, substitution))
}