const regex = /(?<sign>[+-])?(?<int>\d(?:[\d_ ]*\d+)?)(?:(?:\s*[,.]\s*)(?<decimal>\d(?:[\d_ ]*\d+)?))?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<sign>[+-])?(?<int>\\d(?:[\\d_ ]*\\d+)?)(?:(?:\\s*[,.]\\s*)(?<decimal>\\d(?:[\\d_ ]*\\d+)?))?', 'g')
const str = `25
15,81
94.5498
+897
151 516,561 894
89.9894_56
-9`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}