package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<sign>[+-])?(?<int>\d(?:[\d_ ]*\d+)?)(?:(?:\s*[,.]\s*)(?<decimal>\d(?:[\d_ ]*\d+)?))?`)
var str = `25
15,81
94.5498
+897
151 516,561 894
89.9894_56
-9`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}