re = /(http|https):\/\/(www\.)?.+(?<!discord|docs\.google|facebook|youtube|twitter|app\.plex)\.(com|net|org|tv)(.+)?/m
str = 'https://www.facebook.com/username
https://facebook.com/username
http://facebook.com/username
http://www.facebookk.com
https://www.facebookk.com
https://www.google.com
https://www.discord.com
https://www.discord9.com
https://www.app.plex.tv
https://docs.google.com
https://www.twitter.com
https://fictionaldomain1.com/
https://www.twitter.com/agsdag'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end