import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http|https):\\/\\/(www\\.)?.+(?<!discord|docs\\.google|facebook|youtube|twitter|app\\.plex)\\.(com|net|org|tv)(.+)?";
final String string = "https://www.facebook.com/username\n"
+ "https://facebook.com/username\n"
+ "http://facebook.com/username\n"
+ "http://www.facebookk.com\n"
+ "https://www.facebookk.com\n"
+ "https://www.google.com\n"
+ "https://www.discord.com\n"
+ "https://www.discord9.com\n"
+ "https://www.app.plex.tv\n"
+ "https://docs.google.com\n"
+ "https://www.twitter.com\n"
+ "https://fictionaldomain1.com/\n"
+ "https://www.twitter.com/agsdag";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}