import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(Public|Private)?(?:\\s*)(Function|Sub)(?:\\s*)([a-zA-Z_]\\w*)\\s*(?:\\()([^)]*)(?:\\))(?:\\sAs\\s)?(\\w*)?([\\s\\S]*?)^\\s*(?:End Function|End Sub)";
final String string = "Attribute VB_Name = \"mdl_WbkInits\"\n"
+ "Option Compare Database\n\n"
+ "Function InitWbk_004(byRef wbkRef As Object)\n"
+ " Dim wbk As wbk_004_InstoreBrief\n\n"
+ " Set wbk = New wbk_004_InstoreBrief\n\n"
+ " Call wbk.wbk_Init(wbkRef)\n"
+ " \n"
+ " Set InitWbk_004 = wbk\n"
+ "End Function\n"
+ "Public Function InitWbk_003(ByRef wbkRef As Object) As Object\n\n"
+ " Dim wbk As wbk_003_3DCalculation\n\n"
+ " Set wbk = New wbk_003_3DCalculation\n\n"
+ " Call wbk.wbk_Init(wbkRef)\n"
+ " \n"
+ " Set InitWbk_003 = wbk\n"
+ "End Function\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}