using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*(Public|Private)?(?:\s*)(Function|Sub)(?:\s*)([a-zA-Z_]\w*)\s*(?:\()([^)]*)(?:\))(?:\sAs\s)?(\w*)?([\s\S]*?)^\s*(?:End Function|End Sub)";
string input = @"Attribute VB_Name = ""mdl_WbkInits""
Option Compare Database
Function InitWbk_004(byRef wbkRef As Object)
Dim wbk As wbk_004_InstoreBrief
Set wbk = New wbk_004_InstoreBrief
Call wbk.wbk_Init(wbkRef)
Set InitWbk_004 = wbk
End Function
Public Function InitWbk_003(ByRef wbkRef As Object) As Object
Dim wbk As wbk_003_3DCalculation
Set wbk = New wbk_003_3DCalculation
Call wbk.wbk_Init(wbkRef)
Set InitWbk_003 = wbk
End Function
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}