re = /^(?:^git@|^https?:\/\/)(?:[^@]+@)?([^:|^\/]+)\/?:?([^\/]+)\/([\w\d.\-_]+)(?:\.git)?$/
str = 'https://github.com/swalker2/rdo.blog.br'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end