package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:^git@|^https?:\/\/)(?:[^@]+@)?([^:|^\/]+)\/?:?([^\/]+)\/([\w\d.\-_]+)(?:\.git)?$`)
var str = `https://github.com/swalker2/rdo.blog.br`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}