import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http:\\/\\/dx.doi.org\\/10|10| DOI: 10|DOI:10).\\d{4,9}\\/[-._;()\\/:0-9]+";
final String string = "Small Group Research2014, Vol. 45(6) 671 Œ703© The Author(s) 2014Reprints and permissions:sagepub.com/journalsPermissions.nav DOI: 10.1177/1046496414552285sgr.sagepub.comArticleA Conceptual Review of Emergent State \n"
+ "Measurement: Current \n"
+ "Problems, Future \n"
+ "SolutionsChris W. Coultas1, Tripp Driskell2, C. Shawn Burke1, and Eduardo Salas1AbstractTeam research increasingly incorporates emergent states as an integral \n"
+ "mediator between team inputs and outcomes. In conjunction with this, we \n\n"
+ "have witnessed a proliferation and fragmentation of measurement techniques \n\n"
+ "associated with emergent states. This inconsistency in measurement presents \n"
+ "a problem for scientists and practitioners alike. For the scientist, it becomes \n"
+ "difficult to better understand the nature and effects of various emergent \n\n"
+ "states on team processes and outcomes. For the practitioner, it complicates \n"
+ "the process of measurement development, selection, and implementation. \n"
+ "To address these issues, we review the literature on emergent states focusing \n"
+ "on various measurement strategies, to better unpack best practices. In so \n"
+ "doing, we highlight existing research that suggests innovative solutions to the \n"
+ "conceptual, methodological, and logistical problems that consistently plague \n"
+ "emergent state research. Our aim is to enhance emergent state theory by \n"
+ "applying psychometric principles to the measurement techniques associated \n"
+ "with them.1University of Central Florida, Orlando, USA2The Florida Maxima Corporation, Orlando, USACorresponding Author:Chris W. Coultas, University of Central Florida, 4000 Central Florida Blvd., Psychology Bldg. \n"
+ "99, Ste. 320, Orlando, FL 32816, USA. \n"
+ "Email: ccoultas@ist.ucf.eduThis article is part of the special issue: 2014 Annual Review Issue, Small Group Research, Volume 45(6).552285SGRXXX10.1177/1046496414552285\n"
+ "Small Group ResearchCoultas et al.research-article\n"
+ "2014\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}