#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(http:\/\/dx.doi.org\/10|10| DOI: 10|DOI:10).\d{4,9}\/[-._;()\/:0-9]+"
Local $sString = "Small Group Research2014, Vol. 45(6) 671 Œ703© The Author(s) 2014Reprints and permissions:sagepub.com/journalsPermissions.nav DOI: 10.1177/1046496414552285sgr.sagepub.comArticleA Conceptual Review of Emergent State " & @CRLF & _
"Measurement: Current " & @CRLF & _
"Problems, Future " & @CRLF & _
"SolutionsChris W. Coultas1, Tripp Driskell2, C. Shawn Burke1, and Eduardo Salas1AbstractTeam research increasingly incorporates emergent states as an integral " & @CRLF & _
"mediator between team inputs and outcomes. In conjunction with this, we " & @CRLF & _
"" & @CRLF & _
"have witnessed a proliferation and fragmentation of measurement techniques " & @CRLF & _
"" & @CRLF & _
"associated with emergent states. This inconsistency in measurement presents " & @CRLF & _
"a problem for scientists and practitioners alike. For the scientist, it becomes " & @CRLF & _
"difficult to better understand the nature and effects of various emergent " & @CRLF & _
"" & @CRLF & _
"states on team processes and outcomes. For the practitioner, it complicates " & @CRLF & _
"the process of measurement development, selection, and implementation. " & @CRLF & _
"To address these issues, we review the literature on emergent states focusing " & @CRLF & _
"on various measurement strategies, to better unpack best practices. In so " & @CRLF & _
"doing, we highlight existing research that suggests innovative solutions to the " & @CRLF & _
"conceptual, methodological, and logistical problems that consistently plague " & @CRLF & _
"emergent state research. Our aim is to enhance emergent state theory by " & @CRLF & _
"applying psychometric principles to the measurement techniques associated " & @CRLF & _
"with them.1University of Central Florida, Orlando, USA2The Florida Maxima Corporation, Orlando, USACorresponding Author:Chris W. Coultas, University of Central Florida, 4000 Central Florida Blvd., Psychology Bldg. " & @CRLF & _
"99, Ste. 320, Orlando, FL 32816, USA. " & @CRLF & _
"Email: ccoultas@ist.ucf.eduThis article is part of the special issue: 2014 Annual Review Issue, Small Group Research, Volume 45(6).552285SGRXXX10.1177/1046496414552285" & @CRLF & _
"Small Group ResearchCoultas et al.research-article" & @CRLF & _
"2014" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")