// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[+·`\-::]*?([\u4e00-\u9fa5]+)[+\-十](\d+([.::]\d){0,2})(%|0/0|0\|0|010)?").unwrap();
let string = "·暴击伤害+21.2%
·元素精通+11
暴击率+17.1%
+攻击力+20
·防御力+98
`防御力+21.7%
`生命值+2147
-攻击力+15.70/0
·暴击率+3:9%
防御力+31:0%
暴击伤害+46.6010";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}